nov
20

[Risolto] Problema Webcam su DELL XPS 1330 e 1530 su Ubuntu 8.10

 

Per tutti i possessori di Dell XPS 1330 e 1530 che hanno installato Ubuntu 8.10 ho una buona notizia .. come sapete la nuova distro (debian Based) Ubuntu 8.10 chiamata anche Intrepid Ibex è da poco uscita ma si è subito adattata bene all’hardware DELL , tranne che per qualche componente come la webcam che pur essendo subito rilevata ed installata non funziona a dovere , il led di stato si accende ma non si riesce a vedere alcuna immagine ne con cheese ne con skype.

L’altro giorno ho aperto un post sul forum ufficiale Ubuntu e oggi in contemporanea alla segnalazione di  un post sempre dal forum ubuntu da un amico Malex (www.malex.org) ho ottenunto una risposta molto utile e positiva per la risoluzione del bug.

La procedura da seguire è la seguente:

installiamo i moduli backports

sudo apt-get install linux-backports-modules-$(uname -r)

e poi si procede con questa serie di comandi sempre da terminale

sudo apt-get install subversion build-essential linux-headers-$(uname -r) &&
svn checkout svn://svn.berlios.de/linux-uvc/linux-uvc/trunk &&
cd trunk &&
make uvcvideo &&
sudo install uvcvideo.ko -v -m644 /lib/modules/$(uname -r)/kernel/drivers/media/video/uvc/uvcvideo.ko &&
sudo make install &&
sudo cp -av /lib/modules/$(uname -r)/kernel/drivers/media/video/uvc/uvcvideo.ko /lib/modules &&
sudo depmod -ae $(uname -r)

Dopo aver eseguito questo riavviamo il sistema e testiamo la webcam.

Il presente How-To è basato sui seguenti post del forum Ufficiale Ubuntu http://ubuntuforums.org/showthread.php?t=987023 e http://ubuntuforums.org/showthread.php?t=966398 ho voluto pubblicare la procedura sul mio blog proprio per facilitare ulteriormente la procedura a tutti gli user Italiani (e quelli che non amano tanto cercare ..)

Popularity: 1% [?]



Puoi visualizzare il post originale qui.

set
20

Modulo ovcvideo.ko in conflitto con V4L e Mercurial

 

Salve, ieri smanettando sul mio notebook volevo installare la mia Yakumo QuickStick DVB Usb anche sul mio Dell XPS 1330 con Ubuntu 8.04 .. dopo aver seguito la procedura descritta sulla mia guida : Installare Yakumo QuickStick Basic DVB-T su Fedora 6 procedura funzionante alla perfezione anche su Ubuntu e Fedora 9 mi sono imbattuto in un terribile problema ! La webcam integrata non andava più !

La mia webcam (Bus 007 Device 003: ID 05a9:7670 OmniVision Technologies, Inc.)

Ho fatto un po’ di indagini e il modulo da cui dipende la web è ovcvideo.ko riferito al driver ovc di BerliOS scaricabile da :

svn co svn://svn.berlios.de/linux-uvc/linux-uvc/trunk

Dato che il modulo non veniva caricato avevo pensato che i driver erano saltati , scarico la versione
aggiornata dei driver li compilo e li installo .. verifico il modulo e non viene inserito.

Facendo delle ricerche su google mi imbatto in post della BerliOS : http://lists.berlios.de/pipermail/linux-uvc-devel/2008-February/003104.html che individuano il problema ad un conflitto dei driver V4Linux nuovi e compilandosi con moduli v4l-experimental creano problemi al modulo ovcvideo.ko e non permettono quindi alla webcam integrata di funzionare.

in questo post http://lists.berlios.de/pipermail/linux-uvc-devel/2008-February/003104.html si descrive  una procedura risolutiva che ho tentato anche se non è funzionante almeno per quanto ho provato io :

I’ve copied
Module.symvers from the v4l-dvb tree to linux-uvc tree and recompiled.

questo viene indicato come procedura da eseguire ma cercando il file Module.symvers in v4l-dvb non l’ho trovato, ne ho trovato solo uno in

/lib/modules/`uname -r`/build/Module.symvers

ho provato a sostituirci quello ma ricompilando i driver il modulo ovcvideo.ko nn viene inserito comunque

Ora siccome dovevo recuperare l’uso della mia webcam ho trovato un modo semplice ed indolore per recuperarne la funzionalità , a discapito dei driver v4l-dvb .

Bisogna o via apt o synaptics reinstallare i seguenti pacchetti riferiti al kernel in modo da perdere i moduli compitati in precedenza:

linux-image-2.6.XX-XX-generic
linux-ubuntu-modules-2.6.XX-XX-generic

Al posto delle XX ci devono essere le cifre della vostra versione kernel attuale.

Dopo aver fatto questo riavviate il sistema e testate la webcam!

PS. naturalmente il problema non è nuovo per utilizzare entrambi i driver bisogna attendere la nuova versione v4l che risolva il problema con OVC.

Popularity: 1% [?]



Puoi visualizzare il post originale qui.

top